My game is zoomed out when running my web exports on Mac

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Marshall Demirjian

When I export my game to Web(HTML5), using any web browser on a Mac, things are displayed zoomed out compared to other platforms (running in editor on Mac/Windows, exporting to web and running on Windows, all show it normally).

Also it is important to note that it is not just simply some scaled version of the others. The UI is roughly half the size, but maintains my positioning rules, and cameras in the scene are also roughly zoomed out to show double the space. Here is an example of two identically sized windows, the first running on Windows & the second on Mac (both on chrome):

Windows Image Imgur: The magic of the Internet

Mac Image Imgur: The magic of the Internet

I have seen similar things about some HdDPI setting but I have tried both disabling and enabling this and it had no effect. I am guessing this has to do with the Retina display but I don’t know how to deal with it. I also am not sure whether this is a setting I need to change in Godot or perhaps something I need to change in the HTML file for web exports.

Any help would be greatly appreciated!

:bust_in_silhouette: Reply From: Binney

We had the same problem with our HTML5 export running on my PC with a retina screen!

I spent a while playing around with the project settings too and have found a combination which makes it look like I’d expect it to look:

Project Settings > General > Display > Window > Stretch
Mode: 2d
Aspect: keep

And based on this reply it sounds like it’s a good idea to avoid tweaking the “allow HiDPI” setting unless you know what you’re doing (which I don’t).