My leaves on my tree isnt casting shadows but the trunk is

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Dragon20C

picture : Legobet88 🀄 Trustworthy Agen Situs Slot Online Bet88 Terpercaya Ter- Gacor Hari Ini 2024

I have this tree I made in blender and I have imported it as a gltf and a fbx, fbx on the left and gltf on the right but I dont know why the leaves dont cast shadows I think I have all the options enabled for shadows to appear the trunks are casting shadows but not the leaves what options should I do to fix this?

the leaves are planes is that something to do with it?

:bust_in_silhouette: Reply From: darkshadow

Try a texture without transparency/alpha and see if that has a shadow. You might need to tweak the settings or use another shader for transparent textures to cast shadows

I will try a different texture though I don’t think it willmmake a Difference.

Dragon20C | 2021-06-09 10:06

:bust_in_silhouette: Reply From: Yaann

Go to the Spatial Material of your tree and set depth draw mode to depth pre-pass alpha, further info in the docs.

This looks more promising, I will try it when I can!

Dragon20C | 2021-06-09 11:32

it worked fantastically

Dragon20C | 2021-06-09 14:13