My projects won't run on Android after updating from 3.1 to 3.2.1

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By VilkinJukka

My projects worked fine on Android with Godot 3.1. Today I updated to 3.2.1 and now all I get is the Godot splash screen followed by a black screen.

I created a new empty project with only on sprite in the scene to test if I would get same results and yes I did. Same splash screen followed by black screen.

Next I tried to look for an error using adb logcat. This is the result: Logcat -

This error just after loading the project resources caught my eye:

W Adreno-ES20: <core_glFramebufferTextureLayer:126>: GL_INVALID_OPERATION

I tried Googling, but found nothing. Thanks in andvance!

If you got a test project to share, you should report this to the issue tracker.

Zylann | 2020-04-16 12:34

Please delete all import files and let it import autoly again

Okan Ozdemir | 2020-04-19 03:48

I’ve got the same issue on a slightly older Android phone (Moto G2 2014). It supports OpenGL ES 3.0 so, GLES3 should work fine. But it doesn’t work.

wombatwingdings | 2020-07-06 11:00

:bust_in_silhouette: Reply From: strct

I got this error message and changing GLES3 to GLES2 worked for me.