My text is blurry as if stretched, but I can't find where it's being stretched if that's the case

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Charlie

I have a screenshot but don’t see an easy way to post it here.

Anyway, my in-game text looks to me like it’s blurred from stretching 2x or maybe a lot more. Problem looks about the same for default font or a custom DynamicFont set to any size. This is in all of my Control nodes. The Control nodes are nested in other Controls all the way up to a parent Control node that is child of my base Spatial node. I checked rect_scale and it is (1, 1) all the way up. The base Spatial has scale (1,1,1).

In Project Settings, Display, Window, Stretch:
Mode = disabled
Aspect = ignore
Shrink = 1

Note: My editor text is very sharp. However, the editor 2D scene viewer (if that’s what it’s called) looks kind of intermediate to me. Not as sharp as other editor text, but not as blurry as my in-game text. (But slight blur here may be stretch due to editor zooming since I can’t figure out how to set zoom to exactly 1:1.)

Any ideas where my problem might be?

:bust_in_silhouette: Reply From: Charlie

OK, I found my own answer by clicking random settings until something good happened. In Project Settings, Display, Window, Dpi:
Allow Hidpi: changed this to ON
Now everything looks great. Without this, my whole display window was stretched maybe almost 2x.
It seems strange to me that this is OFF by default. I’ve been living with a terrible appearing screen and wasn’t aware of the situation until I added some text and it became impossible not to notice.

Thanks, helped me too

alanparsons | 2019-02-08 01:57

This fixed the default font for me but my ttf and otf fonts are still blurry. Better than nothing though so thanks!

Allworld | 2019-02-15 17:01

Oh nice. I’ve been looking for this answer for a while.

hidemat | 2020-02-11 16:55

Great! It solved my problem!

pedrozoalencar | 2020-04-23 15:56