No console output when debugging on Android device

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By i_love_godot

Godot 3.2 BETA 3


I’ve been testing my app on an Android phone (Samsung Galaxy S7 Edge) and the console output has suddenly stopped working and I’m getting the following message


The app installs and runs fine, it’s just the console output that seems to be missing. I don’t recall changing anything that could account for it. Running the app in the editor outputs to the console as normal.

I’ve checked the “Disable Stdout” option in settings, and that’s unchecked. I’ve also checked my project.godot file for anything out of the ordinary. I’ve tried restarting both the PC and the phone, but nothing has helped.

Has anyone else experienced this? Any help would be great. Thanks! :slight_smile:

I’m getting this too, comparing 3.1.2 and 3.2 beta the listening ip changes from localhost (which worked on 3.1.2) to (suddenly nolonger working on 3.2 beta), I’ll be posting a github issue to hopefully see what’s going on and if it can be fixed

edit: I have posted my issue here: Unable to debug Android game over USB in 3.2 beta3 · Issue #34376 · godotengine/godot · GitHub - I don’t know if we have the exact same issue but it may be related

smt | 2019-12-16 03:26

So console output has never worked for you when using a beta version? It was working fine for me on the latest beta, but just stopped. Very strange.

I’d be interested in a link to your Github issue, if you do create one. It would be really helpful if there was a fix for this.

i_love_godot | 2019-12-16 03:45

I’ve only ever tested it on 3.1.2 and the 3.2 beta, 3.1.2 works fine, I get all the output, I can monitor my game and debug it over USB, in 3.2 it just says no USB connection and I get nothing, so I have no idea what causes it, if yours is broken in 3.1.2 too it might not be the same issue but it’s possibly related, maybe

smt | 2019-12-16 03:51

I’ve not used 3.1.2 but the beta was working fine. I may try beta 2 again and see if there is any difference between that and beta 3. May narrow it down little.

i_love_godot | 2019-12-16 03:56

Just reverted back to 3.2 beta 2… and the console outputs normally on Android. It’s looking more like an issue with beta 3.

i_love_godot | 2019-12-16 04:14

interesting, mine is the same too, I’m curious, do you see this in in godot’s console in beta2:

0 param: --remote-debug
1 param: localhost:6007

but this in beta3?:

0 param: --remote-debug	
1 param:	

edit: nevermind, I don’t think this is related at al l

smt | 2019-12-16 04:26

I just checked this, and yes I do see this difference. localhost on the working beta 2, and on the non-working beta 3.

i_love_godot | 2019-12-16 14:42

I thought it might have been related but I don’t think it is, just seems like some extra checking is done in the latest beta that’s a bit fiddly/not working very well for windows, but they know now so hopefully it’ll get fixed soon

smt | 2019-12-16 14:46

Well I’m glad it’s a known issue and a fix is on the way :slight_smile:

i_love_godot | 2019-12-16 14:48

:bust_in_silhouette: Reply From: DavidPeterWorks

It worked for me.