no shadow with viewport ?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By nonomiyo

I made a similar setup as the one in the demo “2D in 3D viewport” :

On the video, the red mice is a Sprite3D and the green one is a sprite 2D in another scene, shown in 3D via Viewport. (I made this setup as it allows to assign some shaders to the 2D sprites in the process : outline and color change)

But even though the shadow is shown in the editor (thanks to the Opaque Pre-pass), it is not there when running the game. (Godot 3.1 alpha 2)

Any idea why it disappears ? :confused:
Thanks !

after more tweakings, it appears that only the SpotLight and the OmniLight are missing their shadow. The DirectionalLight doesn’t have this problem…

nonomiyo | 2018-11-27 19:47

:bust_in_silhouette: Reply From: hexaquo

I had a similar issue and fixed it by increasing the ‘Size’ parameter in the ‘Shadow Atlas’ section of the Viewport. Although for me, DirectionalLights were affected as well.