Node editor having limited options

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Nathcra

When I right click on nodes, I’m not getting all the options that I would usually get. Instead, I get these options:

  • Expand / Collapse all
  • Attach Script
  • Copy node path
  • Open documentation

I tried resetting my editor settings, but nothing happened. Thank you in advance!

EDIT: I found out that I had accidentally turned off Scene Tree Editing in the editor feature menu. It works now.

Can you extend your description of situation?

sash-rc | 2021-12-27 09:52

Usually, I would get all the node options that you would need. For example, I used to be able to delete a node, or rename it. Now, I can’t use mouse shortcuts in the scene tree to do stuff either. Double clicking will not rename a node. It feels kind of like a read only scene tree. I don’t know if this is an editor setting that I need to change, or something else.

Nathcra | 2021-12-27 17:18