Noticed that the "Antialiased" setting on 2D polygons doesn't seem to do anything.

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By KnightNine

The Anti-aliasing on 2d polygons doesn’t seem to do anything.
Is this only an issue with the test window?
If not, are there any fixes or alternatives/workarounds for this?

This is a 36° slope if you want to try reproducing this.
with anti-aliasing
without anti-aliasing

Glad to know it’s not just me. But I have the stable version of 3.2 and it still doesn’t work.

I should clarify actually, because I’m talking about Line2D and this is Polygon2D. So I don’t know about Polygon2D, but anti-aliasing for Line2D doesn’t work in Godot 3.2.

TheSecurityDev | 2020-02-06 00:24

:bust_in_silhouette: Reply From: billyb

I can confirm that on 3.1.2, running linux. antialiasing checkbox does nothing. Also, using gscript to set with set_antialiased(true) or myPolygon.antialiased = true also does nothing.

:bust_in_silhouette: Reply From: Calinou

This should be fixed in 3.2 beta4, as this pull request was merged.

:bust_in_silhouette: Reply From: SdSaati

You should turn off HDR in your project settings, then your polygon2D anti-aliasing will work, but there is still a real problem here, when you turn off HDR, then if you write shaders, they will be so different in the output of the game. I hope this problem be fixed as soon as possible.