Objects overlay UI

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By BoneFort

Created the UI and the player. But I can’t see them. They are higher in the hierarchy. What to do? Thank you in advance

This got downvoted (not by me), but I see why. First the image isn’t showing but the real issue is you’ve not really given us anything to go on.

How about you have another crack at defining the problem so we have a chance of helping you out. Maybe include a snippet of the problem code (properly formatted please!), let us know what the node tree looks like.

You need to spell out exactly what the issue is with specifics.

DaddyMonster | 2022-07-26 21:07

No code yet. If you turn off the display of “groundNode” and “wallNode”, then you can see that they are rummaged. Here are 2 screenshots, you can see everything there:

Screenshot-44 hosted at ImgBB — ImgBB
Screenshot-45 hosted at ImgBB — ImgBB

So is the UI

Sorry for bad English. I speak through a translator

BoneFort | 2022-07-27 14:50

:bust_in_silhouette: Reply From: Gil-Koren

The order godot renders isn’t determined by the order of the nodes in the scene, but by something that is called z-index (found in the Node2D area in the inspector).
Put the player in a higher z-index and the problem should be solved for it.
As for the UI I suggest re-parenting it to a CanvasLayer node, and play around with the Layer number until you can see it.

Quick note that order in the scene tree actually impact the render order: the bottom nodes will be rendered after tops. But at all you’re right

USBashka | 2022-07-30 01:04

Good addition :slight_smile:

Gil-Koren | 2022-07-30 08:10