OpenGL out of date for Godot in VirtualBox with Mint

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By MikeyZman

I have Linux Mint installed (64-bit) in a Virtualbox machine. In that machine, I was able to unpack Godot and export templates as well as the isometric game demo (to start with). I have imported the isometric game demo just fine, but when I got to run it, I get the error “Unable to initialize Video Driver”.

I ran glxinfo | grep “OpenGL version” and my opengl version is

OpenGL version string: 2.1 Mesa 18.0.5

I understand from reading many topics that my installed openGL is inherited from the guestbox additions. Another post said Oracle or whoever updated the guestbox additions is not really supporting newer openGL versions, they stopped at 2.1 I guess?

Does anyone know how I can update my openGL version from within the virtual machine? I’ve tried apt-get and all those updates, nothing seems to work. Other things to consider is yes I have 3D acceleration on for the VM.

How much video memory does the VM have?

MmTtDeveloper | 2019-05-05 22:01