OS Error when trying to compile Godot 3.4.4 for Windows

Godot Version

3.4.4-stable

Question

Hi, I’m trying to compile a build of Godot 3.4.4 with GodotSteam included for Windows. I’m compiling my own build because Godot 3.5.3 causes errors in my project when I load it with that version. When I try to compile though, I get an OS error that I don’t understand:

I’ve followed all of the steps in this guide for Godot 3.4 compiling: Compiling for Windows — Godot Engine (3.4) documentation in English
The errors seem to be pointing to scons, but I checked that it’s installed correctly using scons --version, which says that version 4.6.0 is installed. I even uninstalled and re-installed it fresh.

If anyone can help me with this, I’d greatly appreciate it!

Are you sure to have installed the visual studio community edition?
Take a look here:

PS: if you have issue with the last 3.5,3 why not open a bug issue here?