Particles2D Runtime Error

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Hailrig

I am working on a project for the Indie Game Making Competition 2018 and decided to do it in Godot. I went to implement particles and was confronted with the attached error. I updated windows and re-installed visual c++, but the error does not go away. This error persists, even when I attempt to launch the pre-packaged Godot particles demo. Any assistance on how to resolve this issue would be wonderful!

Thanks in advance :slight_smile:

enter image description here

Is it crashing too when using the non-Steam version? Index of /godotengine/3.0.6/
Also, try attaching an output log if you can by running the exe from a command line.

Zylann | 2018-11-19 18:41

Thanks for your reply! I just tried it on a non steam version of the Godot engine - same issue. Here is an output log.

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

OpenGL ES 3.0 Renderer: AMD Radeon HD 6550D
OPENING: C:/Users/Admin/Desktop/Particlestest (C:::Users::Admin::Desktop::Partic
running cmdline: "C:\Users\Admin\Desktop\Godot_v3.0.6-stable_win64.exe" "--path"
 "C:/Users/Admin/Desktop/Particlestest" "--editor"
OpenGL ES 3.0 Renderer: AMD Radeon HD 6550D

C:\Users\Admin>ERROR: set_path: Condition ' exists ' is true.
   At: core/resource.cpp:78
ERROR: ~List: Condition ' _first != __null ' is true.
   At: core/self_list.h:100

Hailrig | 2018-11-19 18:58

Does the same happen if you try with Godot 3.1 alpha 2? Index of /godotengine/3.1/alpha2/
Can you provide the project so I can test if it happens on my end?
Your graphics card looks old (also it’s an integrated GPU but surprisingly it is said to support OpenGL 4.1).

Zylann | 2018-11-19 19:24

It happened in 3.1 as well.

I would be surprised if it happens on your end - I am just running the Godot 3 particles template and encountering the issue if you wanted to look at it yourself.

My graphics card is quite ancient. It would be unfortunate, though understandable, if my graphics card was simply not able to support the Particles2D node.

Hailrig | 2018-11-19 19:53

Otherwise I can only propose to report your issue on the bug tracker with your computer specs

Zylann | 2018-11-19 20:06

Are you running an laptop?
Try to disable your integrated gpu, laptops are often switching between integrated and external gpu.
amd disable integrated graphics - Google Suche

Christoffer | 2018-11-20 10:58