Pixel art is blurry when I play a scene

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Alex5041

I imported pixel art and turned off filter so it looks crisp in Editor, however when I load a scene pixel art has a slight blur over the edges.

Anyone knows how to fix it? I think the issue is with the viewport, so i tweaked some settings in “Projects Settings” but it didn’t do any good.

:bust_in_silhouette: Reply From: DDoop

I think this is because of your import settings, which are unique to every imported file, not your entire project. There’s some info on the settings in the docs here. I think you need to turn off the filter flag. The import pane lives in the same pane as the scene tree in the editor by default. Just select the resource that you want to modify in the editor file browser, select the import tab next to the scene tree, then uncheck filter.

Also, don’t forget to click Reimport after unchecking Filter in the Import dock.

Calinou | 2020-07-21 07:51

Yes, i get it. I turned off filter flag for each imported file as I have said in the question. With this flag on sprites look blurry even in Editor. But without the flag textures still look a litle bit blurry in a played scene, when I press F5 to run it (however the blur is so slight, that it cannot be seen without zooming in on screen. It’s not a screen problem because I tried zooming other pixel games and they look fine).

Alex5041 | 2020-07-21 20:04

You may have to enable Display > Window > Dpi > Allow Hidpi in the Project Settings to prevent Windows’ DPI scaling from making the project window blurry. (This is already done for the editor window.)

Calinou | 2020-07-23 08:01

It helped, thank you so much!!!

Alex5041 | 2020-07-23 14:01

1 Like

Thank you a lot!