Pixel perfect Light2d Shadows, it's possible?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Ditoga

Is there any way to make the light2d shadows pixel perfect?
The shadows doesn’t look pixelated in the pixel art game.

Have you tried changing stretch mode to viewport?

p7f | 2020-09-28 16:13

Thanks! with mode to viewport the shadows looks fine. But the problem is that now the overall movements looks jittered. Could it be that this must be accompanied by another configuration?

Ditoga | 2020-09-28 16:19

You should check “Use Pixel Snap” in Rendering->Quality settings… also, have in mind that for pixel art game in viewport mode, is better that all your objects are places in integer positions, as a fractional position would sometimes round to one pixel and sometimes to another and cause some jitter and subpixel distortion

p7f | 2020-09-28 16:23

Great! :slight_smile:
Thank you!!

Ditoga | 2020-09-28 16:26

Glad to help! If that solved your problem, consider posting an answer so it doesn’t remain unanswered.
I could post the answer myself otherwise.

p7f | 2020-09-28 17:04

:bust_in_silhouette: Reply From: Ditoga

I’ve solved it thanks to p7f, by setting Stretch Mode to Viewport.