"Play Project" function doesn't work at all.

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By GailaGanfenbelle

Basically, pressing the ‘play project’ button doesn’t do anything. I can see it create a window that I can alt-tab to, but it appears as all white and disappears when I select it.

I have tried on stock projects from the steam download, there are no error messages on startup or anywhere in the debugger, I’ve tried running as administrator and running using both graphics cards I have on board. The problem has persisted.

I haven’t been able to find anyone else with this problem. Thanks in advance.

Can you see errors in the system console? If you don’t have any, try using a non-steam version of the editor because it should open with a console next to it.
You could also try the following: copy a non-steam Godot executable right next to project.godot, open a command line (Shift+RMB anywhere in the folder and “Open Powershell” in case your OS has that), and run the executable to see if it outputs something.

Zylann | 2019-07-18 12:39

This is a screenshot of the console after loading a stock project and pressing play


GailaGanfenbelle | 2019-07-18 17:14

Do you have a dual screen?

Zylann | 2019-07-22 21:51

Just one screen

GailaGanfenbelle | 2019-07-27 01:26

See the --position 1655,832 on the console. I wonder if your game is actually opening outside of the screen due to this. Or is that specific to your game?

Zylann | 2019-07-27 01:50

I am running stock projects on the steam version, it’s just to control for any issues.

GailaGanfenbelle | 2019-07-29 23:55

:bust_in_silhouette: Reply From: GailaGanfenbelle

Hey all, the problem appears to have fixed itself, I don’t know how but the most drastic new thing I can remember doing was restarting my computer while it was running in a lower resolution. I’m leaving this up just in case someone has the same problem, thanks everyone.