Portrait screen

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By RiqueDiaz

Hi! I’am exporting a game to apk and i made it the size of a android in portrait mode, enable the portrait image in the exportation and let the expand 2d enable on the configurations, but when i open the game (also my friends) it remains in the landscape screen. Could anyone help me?

:bust_in_silhouette: Reply From: AMixOfGeekStuff

Hi. I totally understand if it’s confusing.
I’m not sure what you mean by “let the expand 2d enable”.

Try this:

enter image description here

This works on a template demo project from Godot.

Written Instructions:
Click on “Project” at the top left dropdown menu.
Go to Project Settings.
On the left side, scroll down to Display.
Click on Window.
Under Tablet Driver, switch the width and height.
E.g. if width is 1024 and height is 600,
change width to 600 and height to 1024 so that the game window is a tall vertical portrait rectangle.
Under “Handheld”, change Orientation to Portrait.

This should work.

If it doesn’t, then, another step you could try is:
Project > Export > Presets > Android (add it if you haven’t arleady),
Options tab > scroll down to Permissions,
Scroll all the way down to “Set Orientation”.

One forum post mentions Project > Export > Android > Options > Orientation > Portrait
but I can’t find this option on Godot 3.3.2