Possible Glitch with AnimatedSprite?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By WinterStep

Note: If this is already known, I’m sorry for bringing attention to it. I didn’t see anything at first, so I assumed no one asked about it yet.

I first encountered the glitch around 5 or 6 days ago, which prompted me to ask this question. I originally believed this may have been my error, but now I’m not so sure. I began working on another inherited scene involving player projectiles, with the main projectile using an animated sprite. However, I encountered the same issue in my previous question, being that the animation could not be found. Which was strange because I copied and pasted the names into it. It only played the default animation.
When I closed and reopened it, the animations were gone. I remade them, but then I got the same error. So I decided to check if the animations were disappearing. I closed out again and reopened it and the animations were gone again.

I don’t know exactly what causes this, and the only real ‘fix’ I found is creating an entirely new Animated Sprite node instead of inheriting it. If anyone knows any other workarounds, or a way to keep the inherited node, please let me know.

Current Version: 3.2.2 Stable
Steps to repeat Bug as best as I could remember

  1. Create a new project or use a current one
  2. Create a scene. It must have an AnimatedSprite2D node
  3. Create a default animation using SpriteFrames
  4. Create an inherited scene from this scene.
  5. Create new animations in new scene (images or spritesheet doesn’t
    seem to matter)
  6. Create a new script (GDScript). Make it play one of the new
  7. Play in main scene or in test scene
  8. You should be getting an error that there is no animation of that
  9. Close Godot
  10. Reopen Godot, and open the inherited scene.
  11. Check Spriteframes. All the new animations should have vanished

I ran into something similar in the Github game jam game I was working on. Actually almost the exact same scenario too. I’d recommend creating an issue on Github if you haven’t already.

Kyle Szklenski | 2020-12-04 17:59