Problem crashing when openning to EDIT

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By tattauhe

When I’m opening the editor, this message appears after a few minutes waiting for it to open, and it just crashes afterwards, sometimes I get the BSoD
message: alloc_static: Condition ’ !mem ’ is true, returned: __null
At: core/os/memory.cpp:87.

I really don’t think is my computer, since I have a nvidia 1080 ti gtx video card, and 879 gb space free.

I don’t want to quit my project, please help.

Error screenshot

Which Godot version do you use?

How much RAM does your PC have?

Does this occur on any project or on a specific project?

If it is a specific project then does it contain any very big resources?
I.e. how big is the scene which the editor tries to open?

Did this happen from start on? If not, what did you change before the error occured?

Waiting several minutes is quite unusual. I’d expect a scene containing at least gigabytes of data.

The error message indicates that the system is out of memory. (Allocation failed)

There are two possibilities:
a) The loaded resources actually don’t fit in your RAM
b) Something went wrong while loading somehow forcing the system in an endless loop. Could be a corrupted file or a bug.

wombatstampede | 2019-11-14 11:42

Currently using Godot 3.1.1

16Gb RAM

Specific project

Yes it does contain somewhere around 2Gb.

I was copying some images before this happened, it started when the images where importing, it crashed and never opened again.

tattauhe | 2019-11-15 00:54

Your project has an .import folder. That’s where all imported/converted resources go.
You could just clear it (after making a backup copy of your project), then all files will get re-imported but you could also sort the contents by modification date. Then you can identify what was added most recently. Remove those files and also (temporarily) remove the corresponding original files/images which you copied to the project.

If starting up still fails then start up godot using the “-v” parameter and your project directory. Type “ --help” to see all parameters.

“-v” will typically let godot (also) list the resources it is currently loading in the output window. So you should see where problems or unusual slowdowns occur.

wombatstampede | 2019-11-15 07:28

I finally could access it after lots of attempts. I deleted a bunch of images and some scenes, is there a limit to the memory I can upload to a project?

tattauhe | 2019-11-16 16:52

The limits are that the loaded scenes and (used resources) have to fit into RAM and sometimes GPU memory (textures). Not all at scenes/resources at once. Only those which are directly embedded/linked to the currently opened scene. It all depends on how the resources are organized. Typically many resources are loaded on runtime when needed and therefore don’t occupy the RAM all the time.

Also every resourrce has to be evaluated in terms of size and resource consumption. If a scene doesn’t even fit in your 16GB then what do you exepect on the players side?

Maybe there is some automatic generated data, maybe embedded into a scene which wastes much of space.

wombatstampede | 2019-11-17 12:31