Problem with exporting to android (missing debug symbols .so)

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Brotap


i want to turn my project into an android app and I think I followed the steps correctly.

I exported the apk few times and it worked perfectly, but now Android Studio tells me that the exportet apk have missing debug symbols.
The User “Krippi” had the same problem and asked it here, but he got a solution by himself and didnt told the community how to fix it.

I created a new project and then the apk installed fine, but after continuing programming and exporting few times (it was like an hour) the app cant install again.

When I create the apk and drag and drop it into my smartphone and want to install it, it tells me the app cant be installed.

Im a programmer beginner and this is killing my motivation :confused:

HUGE THANKS if u can tell me the solution.

i used Godot 3.2.2 stable and had this problem. I updated to Godot 3.2.3 stable (newest version) but still have the same problem.

i hope my bad english was not frustrating you x)

:bust_in_silhouette: Reply From: Brotap

Ok i found myself the solution.

It’s because i had a sprite in my folder named “BackgroundButton-weiß.png”
And the cmd in the background of Godot was giving me a tip. It’s not allowed to have a document/picture with a “ß” in the name. So i renamed it in something else and it worked.

So if u have this problem aswell u might be a german :smiley: