Problems compiling Steamworks SDK into Godot

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By qweide


I’d like to release my game on steam, therefore I need to get a version of Godot (3.1) that contains the Steamworks SDK.
The Steamworks site brought me to a third party module called GodotSteam.
The SDK is put into that module and then the engine should be compiled containing that module.
I read the Compiling for X11 documentation article (I am using Ubuntu 64 bit by the way) and tried to compile it, but it would always fail due to usage of the nullptr keyword. The errors only occur inside the actual Steam SDK files, not the module files itself. The error says something like nullptr was not declared in this scope, which makes sense since I think it is meant to be the C++11 keyword, not a variable.

I did not find a solution to this problem, so I tried the pre-compiled version offered by the creators of the module, but when I try to run it, it keeps saying that ; versions GLIBC_2.27, GLIBC_2.29 and ; versions GLIBCXX_3.4.26, CXXABI_1.3.11, GLIBCXX_3.4.22 are not found, even though these packages are installed on my computer. I think Godot is just looking for them at the wrong path, because it has been compiled on a different system.

So basically, my question is how do I compile the engine and make sure the compiler is using C++11? (As I think, this would fix the nullptr errors)
Or how do I remap the paths to the dependencies needed by Godot?
Maybe someone had the same problem as I do and knows how to help me :slight_smile: