Problems with exporting my game to Android

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Cobra!

I’m trying to export my game to Android for testing purposes, and not only does it not work, but a phone was bricked trying testing the game!

Trying the Godot remote debugger itself, it crashed the OS and I had to reset.

When I export in GLES3, it just blinks a bunch of garbage to me.

When I export to GLES2, it hangs on the splash screen.

What do I do?

Here is the project in question: Project

It’s… really unlikely to happen. Is it really running normally when in debugger and in .exe? Have you tried using the adb logcat to see what actually happens before your phone “bricked”? There may be some clues found from it.

It may also be because your Godot version. I don’t know about Godot 3.1, but for Godot 3.0, it doesn’t do well in Android field afaik. I’ve ever tried exporting to Android in Godot 3.0.x and my game became mess just because I enabled low_processor_usage_mode.

tam0705 | 2018-12-14 07:11

Same happens to me trying to deploy to Android 4.2.2
My game works fine on Android 5+ though. I tried Alpha 1 and Alpha 3 Godot Builds.
Same results.

Lone Dragon | 2018-12-14 07:31