Project tries to load (deliberately) erased fonts

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By pferft

Hi everyone,

I just erased a whole bunch of unused fonts from my project’s fonts-folder. Everything loads and runs smoothly and all the neccessary fonts are still there.
However, for each erased font there is a “can’t load font xyz” error messages now on startup. Unfortunately the editor doesn’t tell me why it’s still trying to load them and where these fonts might still be used (if I missed some old forgotten label somewhere…).
How could I find out?

:bust_in_silhouette: Reply From: jgodfrey

If it’s easy enough to do, you could try to put the (now erased) font files back in place in your project. Then, right-click each font file (in the FileSystem tree) and select View Owners. This should show you where the files are being used.

If that’s not feasible, you could always just search through the *.tscn files looking for references to the fonts in question. A simple grep, Agent Ransack, or similar search on the entire project structure should find kick them up…

Agent Ransack did the trick, but I needed to change the font-name in the found *.tscn-file itself because I couldn’t reach that part in the editor.

I also tried your first suggestion and could evade the error messages after putting the fonts in again. No owners would be displayed though, so I believe there might be some old font-connections still tumbling around within long forgotten nodes or scripts in folders I should have cleaned up long ago… it appears it doesn’t affect any funcionality if I leave those not-used fonts in or not, ony the error message is irritating if I do.

Nevertheless, problem solved, thank you!

pferft | 2023-05-15 16:32