Random beginner-question: godot tries to load from non existent path

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By pferft

Hi everyone,

the debugger throws me an error:

E 0:00:01.240   _load: Cannot open font file 'res://some-path-that-doesn't-exist-anymore/fonts/UbuntuCondensed-Regular.ttf'.
  <C++ Error>   Method failed. Returning: ERR_CANT_OPEN
  <C++ Source>  scene/resources/dynamic_font.cpp:153 @ _load()

“some-path-that-doesn’t-exist-anymore” is the point: I put my fonts somewhere else, all references done (everything runs smoothly). So I don’t understand why Godot tries to load that font from the old path in the first place. What am I missing?

It’s now better in the new version of Godot (version 3.3.stable.official). It can now detect if something changed in theproject.godot file externally. Consider upgrading your Godot Engine as it’s very compatible with your older version and find all your problems solved

INdIE DeV | 2021-05-14 14:29

Oh, alright, thanks for the hint! Just downloaded.
(There isn’t any way to automatically take over all these export-to-mobile-device implementations, is there?)

pferft | 2021-05-14 18:00

:bust_in_silhouette: Reply From: stormreaver

I run into that a lot when I move stuff around. It’s an annoyance, but that’s the extend of the affect it’s had on my projects. Restarting Godot gets rid of the messages.

A restart couldn’t help me in this case - I messed up importing stuff from a different project (which appears to never go smoothly…).

pferft | 2021-05-12 15:34

:bust_in_silhouette: Reply From: timothybrentwood

Godot keeps meta data about all of the connections you make in the editor. Every file import, every script attachment, every reparenting of a node - it’s all in the meta data. That’s how it’s able to build your projects.

When you mess with things that pertain to a Godot project in your computer’s file system, Godot doesn’t know about that change you made so it keeps the last thing it wrote down in its meta data. When it can’t find the file anymore because you moved it in your file system, it yells at you. Try not to mess with files related to your Godot projects from outside of Godot.

Doing everything within one project would certainly be helpful. This was a classical case of trying to “import” a scene from another project, which always seems to cause trouble, even if I prepare the folders within Godot.

I could find the loose ends by text-searching the .tscn-files and pinpoint the id-numbers (but I’ll surely try my best to avoid that in the future).

Thanks for your explanations!

pferft | 2021-05-12 15:31

Ah yes, that is a pain! The editor should prompt you when it finds something is missing and ask you for the location of the resource it can’t find. It might only do it once though so definitely give it all the resource locations the first time!

timothybrentwood | 2021-05-12 16:05