Remove unwanted border/shadow from focused StyleBoxTexture?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By behelit

I’m using custom a StyleBoxTexture for focused and normal on my buttons, but I still get a antialiased border / shadow around the texture when focused. I’ve tried everything to remove it, but nothing seems to work, it always appears when the button has focus. Please tell me there is a way to remove it.

I can’t see any border/shadow when I set the Custom Styles > Focus to a StyleBoxTexture with the Godot logo (icon.png). Did you set it up correctly?

Dlean Jeans | 2019-07-18 22:04

I’m pretty sure I did… I did it several times. But just now I tried setting a custom theme for the HBoxContainer I was using (problem still there), filled all the other custom styles with StyleBoxEmpty (problem still there), deleted the custom theme (problem still there), and when I made a new custom theme… the problem went away. Very strange. Godot’s GUI skinning options aren’t very intuitive, on top of that… It’s very confusing. At least it works, I guess. haha

behelit | 2019-07-19 00:58

Perhaps you gave it an outline somehow without knowing it. Weird things happen. ¯\_(ツ)_/¯

Dlean Jeans | 2019-07-19 01:33