Scene input doesn't work on second load

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By andersmmg

I have a menu scene and a game scene, and at first the menu works fine, it brings me to the game. But, when I go back to the menu scene, input doesn’t work anymore. The buttons highlight when I hover over them, but nothing else works. Animations, button pressed events, sounds, signals, none of it works. What could cause this? I’ve tried isolating as many possibilities as I can, but it still had the problem no matter what I tried.

Are you pausing the game during scene change?

Asthmar | 2020-04-03 16:34

OH MY GOSH, thanks! I cannot believe I didn’t think of that. It was pausing while in the pause menu, and that’s where the quit to menu button is. So I just made the quit to menu button unpause, then switch scenes. Thanks!

andersmmg | 2020-04-03 17:45

Welcome! Recognized the problem because I’ve done it myself xD

Asthmar | 2020-04-05 09:18

You are my hero! :smiley:

tlz13 | 2020-11-27 12:27

1 Like