Scene not running(?)

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By frozzen

So I have a very simple project in 3.06 stable mono win64. When I’m trying to run the scene/play the game window appears in the background, but it is transparent (I cannot even select it). Scripts are running in the background, the splash screen is loading etc, judging by the console, but isn’t displayed either, seems to cause a bit of flickering when loading.

Running on XPS 13 Win10 x64, OpenGL ES 3.0 Renderer: Intel(R) UHD Graphics 620.

:bust_in_silhouette: Reply From: frozzen

RE: I have managed to find the solution. The problem was caused by the screen dpi (4k).
For those of you who may encounter similar problems: under the project/project settings/general/display/window set allow hidpi on.

Thank you so much this was the exact issue I was having! I was getting ready to assume that Godot just wouldn’t run on my integrated graphics!

Lachlainn | 2019-05-24 01:13

Hai I still get the same problem on my windows machine after changing the settings .

kerupana | 2020-03-30 13:25

Thanks @frozzen - This fixed the issue on my Samsung 4k TV using an hdmi cable.

bandit | 2022-12-20 00:56