Smooth in editor, fuzzy in game

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Nv7-GitHub

Everything in the Godot editor looks smoother than the game produced by it, even though it was made using Godot. The text looks smoother, but also the 3d rendering looks smoother.

Godot game:
enter image description here
enter image description here
enter image description here

Godot editor:
enter image description here
enter image description here

None of these images have been scaled, the tiny text that says Godot has a much lower resolution than the text that says “Menu”, yet it looks much smoother. Are there any settings I can adjust? Thanks!

:bust_in_silhouette: Reply From: JimArtificer

Check your project settings. In particular, the Display > Window settings related to the size of the render target, stretch mode, stretch aspect, and stretch shrink.

It looks like Godot has been instructed to render your scene at a lower resolution and upscale it.

As you go about adjusting these settings back to their defaults to figure out what is causing the issue, I recommend you do this by rendering the game in windowed mode. Your issue could be as simple as thinking your full-screen resolution is set to something different than it is.

:bust_in_silhouette: Reply From: Calinou

This is a known issue. If you use an hiDPI display, this could be due to Windows’ loDPI scaling fallback. To solve this, enable Display > Window > Dpi > Allow Hidpi in the Project Settings (and make sure your project supports multiple resolutions).

I actually have a Macbook, but the HiDpi setting worked.

Nv7-GitHub | 2020-07-26 21:23