Socket Error: 104

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By MisterAcoustic

Hello - very new user here, running into a problem.

(System: Ubuntu 16.04.6 LTS, Mate)

I created my first project (3D), and installed the heightmap addon (xylann.hterrain).

I was able to build a terrain. I saved that as a scene. Created a new scene to be the ‘game’, and instanced the terrain. Added an Interpolated camera.

When I try to run (F5, neither Deploy with Remote Debug nor Small Deploy with Network FS are checked), Godot launches, then quits immediately with the following error:

drivers/unix/net_socket_posix.cpp:199 - Socket error: 104

No other information is given, and I don’t have any idea how to find out what’s wrong.

As far as I am aware, I am not doing any networking.

I can provide my project files, if someone will explain how to do that here, and the best format for the file/s.


I have a similar problem and started a thread as well!

If anyone can help please post on either thread

Error: net_socket_posix - Archive - Godot Forum

edit: oh you commented on that thread xD

Agentfox | 2019-04-14 18:10

My problem is slightly different, though it might be the same in the end. I saw that someone posted a solution on your thread related to the project files you posted. Since I don’t have any scripts of my own running, I figured I had better post separately.

MisterAcoustic | 2019-04-14 18:14

oh I see (I too am a beginner to Godot)

Also, I found out how to fix it, if it helps, I just commented out all the lines and ran it over and over until I found the troublemaking lines:

if get_point_position(1).abs() - get_point_position(2).abs() < Vector2(1,1):
	set_point_position(1, Destination)

it was painstaking, though it worked

I hope you have better luck with your problems :slight_smile:

Agentfox | 2019-04-14 18:20

I’m glad you worked around your issue. In my case, the only script I think should be running is the from the heightmap plugin. I haven’t been able to get it to break in the debugger at all - it seems like it never gets as far as loading that script.

Still hoping for some other ideas.

MisterAcoustic | 2019-04-14 18:34

:bust_in_silhouette: Reply From: MisterAcoustic

Hi All,

I was able to solve my problem - but I haven’t figured out the root cause yet.

I was trying to keep my project on a USB flash drive, so it would be portable and easy to back up.

I decided to copy it to my main drive, to see if the flash drive made a difference.

I opened godot from the new location, and used ‘Import’ to bring in the project. The import process showed a Load Error - my HTerrain was missing it’s data resource. Now, I’m certain this is set up correctly on the flash drive…

I reset the data setting in the heightmap inspector, and ran the project. It worked as expected. Yay!

I have no idea if the problem is related to running from a flash drive, or that somehow the data resource that I clearly established for the heightmap terrain was lost.

I hope this information helps someone else. And I’m off to the races :slight_smile:

:bust_in_silhouette: Reply From: sarbot

Got the same Error as well and couldn’t figure out where it came from. By loading the project (restarting Godot) I got an dependency error (Missing material). Fixing this dependency or in my case just removing the Node that used it solved the Problem.

:bust_in_silhouette: Reply From: pslat

Hi folks, I was getting this error after installing Godot on Kubuntu on an old laptop. Turned out my graphics card can’t handle gls3 and allowing fallback to gls2 stopped the error happening in debug and when exporting an application. You can enable fallback in the project settings - rendering quality section. Hope this helps someone…
Screenshot of rendering quality settings below