[Solved] Godot IDE not working well on Intel integrated GPU (Intel® HD Graphics 620) (Windows 10 64bit)

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By FreelanceMolnar

This question is already solved, but I am posting this because I haven’t seen much support for this specific problem elsewhere.

The IDE behaves strangely with an integrated Intel chip running on the latest drivers for windows 10. A description of the issue can be found below.
The chip in question is the Intel HD graphics 620, running the latest available drivers for windows 10 ( Intel® Graphics - Windows® 10 DCH Drivers Version: )
The solution is to downgrade to the previous driver version:
Note that in order to install an older driver you MUST uninstall the previous one, restart, install the new one, and restart again, or the installation will not work not work.

The problem:
Firstly, the interface does not seem to update at all unless the window is resized, or the mouse clicked within the screen, or the window is moved.
Secondly, the IDE works very slowly for everything, I mean dreadfully slow. In order to import a sample project, an otherwise instant process, the IDE takes 20 seconds.

There may be other problems, however, since I downgraded my driver, that’s all the issues I’ve seen. Do respond if you find anything else.

Thank you for sharing! Though I would have recommended to first post the problem, and then answer it in the “Answer” field.

Ertain | 2019-03-25 17:14