Some translation phrases won't show

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Cobra!
:warning: Old Version Published before Godot 3 was released.

I’m having a problem with adding translations into my project in Godot.

Some of the phrases just won’t show, at all.

Some phrases, such as “LEVEL1” and “CALIBRATE” just won’t show the replacement text, and any labels that have those texts just stay as those text, instead of changing them like it’s supposed to.

I have tested this in 2.2 and 2.1.3, and they both have the same problem.

I’ve recreated the problem in 2.1.3 with a test project: TranslationProblem

What am I doing wrong?

:bust_in_silhouette: Reply From: Nuno Donato

you have some odd character in the CALIBRATE strings, and all strings after that row become unusable. maybe due to some import error.
Removing that character and re-importing the csv file fixed it for me.

I’m not seeing any odd characters, though, they’re all ASCII characters…

Cobra! | 2017-05-10 21:29

Actually, your .csv file does not contain only ASCII characters (there’s ellipsis characters), but this is not where the problem comes from. The issue here is that the file is not encoded using UTF-8 (the established standard in character encoding today), but rather using Windows 1252. This is visible by opening the .csv file in an editor other than the Windows Notepad, such as Visual Studio Code:

Encoding error in .csv file

This also causes the two strings after the erroneous string to not be processed by the engine.

You can fix it by hand (and make sure to save as UTF-8), or use a text editor that can convert between encodings or a conversion utility to fix the issue.

Calinou | 2017-05-11 08:21

Well, I’m using LibreOffice Calc, and I don’t see any option to change the encoding… How do I do it?

EDIT: Nevermind, I figured it out, it works now, thank you guys so much!

Cobra! | 2017-05-12 20:03