Strange UI bug on laptop

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By pajh

Just installed 3.0.6 stable (64bit) on windows 10 home on a new Dell laptop, and I have a strange problem with the user interface. At first I thought it was just slow, but then I realised that it was sort of processing all the user input events ‘one event behind’. For example when I get to the ‘enter project name’ dialog, and I type ‘a’ nothing happens, when I type ‘b’ the ‘a’ appears, when I type ‘c’ the ‘b’ appears. This is consistent with mouse clicks as well, the next event seems to ‘activate’ the previous one.

Any ideas?

Try the Steam version

fpicoral | 2019-01-12 22:39

I am also seeing this issue. This is a hard one to search for. Pajh, did you ever figure out a solution?

The standalone binary is useless because of this. The steam build works better surprisingly. The main difference between the two seems to be that the steam build registers UI events more consistently, particularly mouse-over events. Ex. clicking a box usually does nothing in the standalone version, but moving my mouse will make it work in the steam build. Typing a string in a text box will always type the last character I pressed, as described above. In the standalone build, clicking the confirmation box doesn’t do anything and the last char in the string is still missing. In the steam build, hovering over the confirmation box will make the last character appear, and the button usually works.

I am also on a Dell. The XPS 15 2-in-1 specifically, is this what you have pajh? I’d be glad to help debug it if someone can get me set up with a debug env and/or show me what sections of code I should instrument.


stevenre3d | 2019-03-25 13:40

Same issue. Lenovo ideapad.

Switched to steam version(found the same bug, now don`t know what to do).

Bug is still here in 3.1.

mcurasya | 2019-04-13 20:33

:bust_in_silhouette: Reply From: OldWer

I found this post when searching for the solution to the same problem. I didn’t have any luck finding an answer on the web, but I figured it out myself, so I share it in case somebody comes across the same bug in the future.

I noticed that Godot starts with Intel HD Grapics selected as renderer; when I forced the executable to use the discrete graphics card (I have a Radeon - use Radeon Settings app, click System and look for “Switchable graphics” in the upper right corner; in my case the setting was missing, but it appeared after updating drivers), Godot started using the Radeon card as renderer and the problem was solved.

That is a good solution, but what if you are working on a laptop with only intel graphics? I am having this same issue but I can’t switch the graphics chip I am using. Anyone find the issue of this?

jreneew2 | 2019-09-22 15:01