Tearing on fullscreen

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By fpicoral

Hey there,
Could someone test this project in fullscreen and say me if you get any tearing? Here, when on window mode, everything is fine but if I set to fullscreen I get a LOT of tearing.

If you do get tearing, is this a bug or I messed up with something in the project?

:bust_in_silhouette: Reply From: SIsilicon

Vsync is most likely off. You see this option appears in a lot of games. For a trade of a little performance, it makes sure that your video processor and your monitor keep up with each other. Currently Godot doesn’t have a Vsync option to enable. So look into your computer’s graphics settings and see if you can enable vysnc yourself. If not, there isn’t much you can do about this.

Currently Godot doesn’t have a way of enabling vysnc by itself.

That’s not true, V-Sync is enabled by default in the Project Settings. Moreover, most graphics drivers enforce the use of V-Sync these days, so you actually need to jump through hoops to disable V-Sync (which isn’t a good thing if your game requires low input lag, as V-Sync adds a significant amount of input lag).

Calinou | 2019-01-17 19:15

Sorry. What I meant to say was

Currently Godot doesn’t have a Vsync option to enable.

But if/since it’s true that Godot has vysnc on by default, then what else could be causing the screen tearing? A graphics driver bug?

@fpicoral, have you tried seeing if you can update the graphics driver you’re using?

SIsilicon | 2019-01-17 19:26