TextEdit not displaying Unicode Character '♂' ingame

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By sparkart

Writing :male_sign: works in any textedit box in the editor, but nothing displays ingame. How do you get unicode characters to work in game?

:bust_in_silhouette: Reply From: Ertain

Have you tried changing the font of the text display? Does the font you’re using in the game contain the symbol for Mars?

I haven’t tried yet, but I would assume that it would default to whatever the editor’s font is, which apparently supports it.

sparkart | 2019-10-18 20:10

Maybe the engine doesn’t support all unicode characters (even though the symbol for Mars should be in the Latin-based fonts). From the looks of this issue, other font encoding support is being suggested for use in the engine (alebit in the editor, and not a full game).

Anyway, I tested a font (Deja Vu Sans) in the 3.1 version of the engine, I was able to get it working. Here’s some screenshots to show how it looks.

Ertain | 2019-10-18 21:48

How would I set it to match the default?

sparkart | 2019-10-18 23:47

Are you referring to setting it in the editor, or in the game? To set it in the game, you would have to assign it as the font for that Control. For the editor, go to Editor Settings > Interface > Editor > Main Font to change the editor font.

Btw, this may be a bug. It looks like the variables they use for the font encoding may not be big enough to hold the necessary unicode. You can see the whole issue with using emojis and other unicode symbols here.

Ertain | 2019-10-19 00:12