The editor crashes on launch in linux (ubuntu 20.04), what can I do about it?

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By mysteriousLounger

When I extract and launch the editor, as downloaded from the homepage, the process crashes after a few seconds with a signal 11 (segfault). The troubleshooting page doesn’t mention this issue, so I figured I’d ask a question here. The only other mention I’ve found on the web of something similar is an “ask ubuntu” answer from 2017 that mentions a similar segfault with the provided binaries, see the accepted answer; there, the poster recommends building from source, which at the moment seems to be my best option. If this problem has an easy solution, though, I’d love to know.

I can also try the windows binaries, as I have a dual-boot, but I would prefer to work in Linux if possible.

Which graphics card model and driver are you using?

If all else fails, you can try running the Windows binary using WINE.

Calinou | 2021-09-23 23:25

Have you tried running the binary from the command line? Did the file give an error message?

Ertain | 2021-09-24 06:52

Ertain-- yes, this is how I know that that the failure is a signal 11. the error message basically said “program crashed with signal 11, dumping core” and a bunch of stack trace information that I don’t have on hand right now, but I can certainly grab it again.

Calinou-- this is an interesting question, I have a laptop with two graphics cards (integrated intel 520, discreet nvidia 940m). However, the process stated that it was using the Intel chip in the command line before crashing. The drivers are mesa currently, should be the most recent version, but I can update or switch to proprietary and see if that works. I’ll report back on that.

In the mean time, I’ve moved back into windows, and downloaded the editor here. Everything seems to be in working order with this version.

mysteriousLounger | 2021-09-24 08:37

Update: I’ve built godot 3.X (which I thought was 3.3.3, but was in fact 3.4 beta) from source in Linux, but the situation didn’t change-- the crash still occurs in the same way. I also tried running the windows binary of 3.3.3 through wine, but that also crashed, despite working fine in windows. Wine Debug wasn’t able to attach to the process to obtain a stack trace. Additionally, both the windows binary running under wine and the native binary crash after displaying the following message in the command line:

OpenGL ES 3.0 Renderer: Mesa Intel(R) HD Graphics 520 (SKL GT2)
OpenGL ES Batching: ON
/usr/lib/i386-linux-gnu/ undefined symbol: snd_dlpath

So the drivers are indeed mesa, and it is in fact using my integrated graphics and not my discreet graphics. I downloaded the proprietary drives for my Nvidia card, but when I ran godot again, it was still using the mesa/intel configuration, and I’m not sure of any way to change this.

I again downloaded both of the official 3.3.3 linux binaries (64 and 32, just in case that changed anything) and both gave the same result, although the length of the back trace is not consistent. At this point I’m going to open an issue, as I believe that this is beyond the scope of what I can troubleshoot on my own.

mysteriousLounger | 2021-09-28 09:24