The labels in my project all have a lot of space around the text and I can't find how to change it

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Mortal_Zen

Imgur: The magic of the Internet for a snip of the issue, it makes spacing difficult in gridcontainers and just general plotting of the UI.

:bust_in_silhouette: Reply From: njamster

Select your label in the scene tree and navigate to Rect > Size in the inspector. Click the reset button left of the current value. If that doesn’t solve your issue, then it’s due to the font you’re using. Go to Custom Fonts > Font > Settings > Extra Spacing to adjust your settings. You can insert negative values as well.

I checked all those things, and none of them are more than default, it seems if I set the font in the label itself it’s fine… but if I put it in as the Project Setting custom font it adds the spacing. Wait. It didn’t this time? I don’t know anymore. It’s fixed now, but now I just want to know what happened.

Mortal_Zen | 2020-04-24 13:54

Thanks! I, too, was looking for the way to reduce line spacing! This did the trick!

GiannisG | 2020-11-03 20:55

I this still relevant in Godot 4? I can’t seem to find a " Custom Fonts" menu anywhere

Well I figured it out. For anyone who might be looking for it. You can adjust the line height of a font by instead of just choosing your font, click the arrow down icon next to where you select your font and pick “New FontVariation”. Then when you open up that Font Variation you can select the font you want in there, and you have spacing options under “Extra Spacing”

1 Like