The most strange error in godot I see

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By NaythanFox

Guys, help! I’m exporting my game to windows but it just opens a black screen and closes quickly, I do not know what to do

I exported another game from Godot and it worked perfectly, this error in my view is inside the project, I already disabled the singletons to see if it was but it was not, I already exported previous versions of this project and everything was fine, besides me not I’m trying to get the problem out of the box, but I’m not sure how to do it. questions to know if someone knew how to solve … but nobody knows what to do

EDIT: I ran the game by CMD and something appears now, that error-filled message what is it?

Please don’t replace your previous images next time. This will get hard to understand for users having the same problem but could’nt understand the whole story.

Could you please provide more insights of your project? Interesting infos:

  • The structure of your project files
  • The code you have written
  • A zip containing your project files to investigate it on another machine

rolfpancake | 2018-02-19 16:53

Thanks for the project files. I investigated them and updated my answer - just see my edit. By the way: Nice effects and project structure :slight_smile:

rolfpancake | 2018-02-20 16:49

Thank You :slight_smile: , I continue to work to make a better game

NaythanFox | 2018-02-23 01:54

:bust_in_silhouette: Reply From: rolfpancake

Change your savepath to user:// instead of using res://.
This is explained in the Filesystem docs. You can find further information in the Saving games Tutorial.

Even if it is not always recommended you can use print-debugging to check your projects when getting errors or when it shows strange behavior. Insert a print("App quitted because the file could not be found.") right before your return statement and you will see that something is happening there.

I looked into your project files and you clearly messed something up with your filepaths. I’m not sure why it is not recognized when starting the game in the editor but if you export you can see that files couldn’t be found. This is because you used CamelCase once but your files and folders were renamed or something like that. You only have to recheck all your filepaths in your code.

Following is a list of lines that I had to adapt till the exported game started correctly. The main problem was that you used “Scene” instead of “scene” in arguments for your preload() and change_scene() statements:


game - scenes/

var punch = preload ("res://scenes/gameobjs/socoBox.tscn")










Unfortunately it did not work, but when I start the project it appears

enter image description here

NaythanFox | 2018-02-19 16:26

This message is normal behavior. See my comment below the question.

rolfpancake | 2018-02-19 16:50