The textures on my 3d Models are not showing up properly on mobile browser, help needed.

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By xyber

Hi,
So I am trying out 3D on Godot for the first time. But I am having issue with the textures not displaying properly.

When running the (web) build on a PC browser, it appears fine:

But on mobile browser, it’s kind of a disaster:

Any ideas on why this might be?
I am new to Godot and any help will be appreciated, thanks!

Is Project Settings > Fallback To Gles2 true? It looks like the material’s alpha cutoff isn’t working. Here’s an issue that’s similar to this. It can happen the mobile is falling back onto GLES2.

Magso | 2020-02-28 00:14

:bust_in_silhouette: Reply From: xyber

UPDATE : Hey, so I figured it out. I just needed to enable the VRAM texture compression for mobile. I did that, and the textures are fine.

how did you enable vram compression. i am facing the same issue textures not showing up on mobile

elbert41 | 2021-01-15 19:31

Can you explain how you to enable VRAM?

Synnlaw | 2021-04-12 21:24