TileMap does not let me draw tiles

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By kitfox

I’m learning Godot and trying to create a simple scene with a TileMap. I was able to get me TileSet setup correctly, but seem to be unable to draw any tiles on my TileMap node. Every time I hold down the left mouse button and drag, it just pans the scene. Same when I press and drag any of the other mouse buttons. I have the pencil icon selected on the toolbar for the editor window, but it doesn’t help. Do I have to do something to let my mouse clicks can draw the tiles?

Are you using a trackpad or a normal mouse?

Zylann | 2020-02-24 19:16

A regular three button mouse.

kitfox | 2020-02-24 19:54

:bust_in_silhouette: Reply From: Zylann

Even if the pencil is selected, make sure you also have the “select” tool selected, the mouse icon on the left of the toolbar.

The select mode tool is also selected. My view still just pans around when I left click and drag.

kitfox | 2020-02-24 20:18

I have no idea what’s going on then… maybe a variant of this? Selecting and edit tilemap issues · Issue #34819 · godotengine/godot · GitHub

Zylann | 2020-02-24 20:26

I restarted Godot. Tile drawing works now.

kitfox | 2020-02-24 20:55

1 Like
:bust_in_silhouette: Reply From: Rickers

It’s a little finnicky right now, and if you’ve solved it great. Usually I select the tile i’m looking for and then press “p” or actually select the draw button, it’s annoying as I have to use this every time but I can’t think of a better solution at the moment.