Tilemap doesn't show up when testing

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By ProbablyConfused

I’m having a bit of trouble with a tilemap showing up when I test play the game. It shows up on the nodes and scenes well, it just doesn’t appear when testing the game itself - all I see is the sprite, which is the only thing I’ve added into the game. I tried a Google search and - surprise, surprise - the solution it suggested didn’t work (the solution itself was to delete the tilemap and sprites from Godot, reupload them, and it was supposed to work again if I read it correctly). Does anyone have any suggestions?
I’ll say this now, though; I can be pretty clueless and I don’t always understand big-worded explanations. I thought I’d get that out of the way before I had to ask for someone to clarify.

:bust_in_silhouette: Reply From: TchnlgPsnt

Not sure if this helps, but when test running the game, click back on the editor. Don’t close the game window, but look at the scene editor panel. There should be two new buttons: local and remote. Local displays the status of your scene as is saved in the file, but remote displays the status of your running game window. If you click remote it should display in real time the layout of your game. My first step would be to check this out to see if your tilemap is being deleted somewhere accidentally.

The tilemap still doesn’t show up. Here’s some pictures:

ProbablyConfused | 2021-01-24 14:01

:bust_in_silhouette: Reply From: Dragonn

Hi- a bit late for this question, but hopefully this’ll help others: you probably saved the player as the main scene. You need to make sure you save the world scene as the main, or else that issue occurs.

This works, thanks!

PD: Main scenes in on Project Settings > Application > Run > Main scene

shadypyro | 2023-03-09 17:01