tiles have offset - but rootnodes are set to origin

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By nooberdev
:warning: Old Version Published before Godot 3 was released.

i am following the “using tilemaps” tutorial on the documentation page with the tiles given in the tutorial.
this one

i did like the tutorial said but i get 25x25px offset on a 50x50 grid.
since the rootnode’s origin is at 0,0 with its center, everything has an offset of 25x25.
i checked the snap-in settings, the root node, the sprites, the staticbody etc. and none of them has a offset. they are all positioned at 0,0 and the “centered” option at the sprites is checked.

i cant make a collisionpolygon2d because they snap-in with an offset of 25x25 px.
i tried to give the rootnode an offset of 25x25 px to counter this problem but as soon as i convert it to a tilemap, the tiles get an offset again.

wtf am i doing wrong?
i am trying to solve this problem for 2 days now.

here is a link to a screenshot, so you can better understand my problem.


:bust_in_silhouette: Reply From: quijipixel

I think you are complicating yourself. It does not matter that offset, the minute you put the tilemap, they will snap in the grid as you would expect, on a grid based on the origin and not an offset. If you have trouble with the pixel snap just configure it to snap at 1 px per 1px (and not 10x10 as default). If you set 1x1 you will have all the freedom that you need to snap the polygon shape.

thank you for your reply.

i already configured the gridsnap and i can set sprites with staticbody and a collisionpolygon where i want them to be. unfortunately, this didnt solve my problem.

the problem is the following: i convert the scene with the sprites (with their staticbodies and collisonpolygon children) to a tilemap, i make a new scene with a rootnode, set up a tilemap as child and make it get the .tres resource i converted to earlier. so far so good.

when i now want to “draw” with the tileset, i can highlight a square on my canvas but the tile i picked shows up with an offset of 25x25 relative to the mouse. if i click on a square on the grid, the tile gets placed at the offset, instead of where i highlighted. this happens on my pc with win10, steam-version of godot.

i now tried the whole process again on my laptop (ubuntu 16.04) and didnt had any troubles making a tileset and drawing a tilemap with the converted resource. this might be a bug. i’ll try re-installing the steam version of godot on my pc and if this doesnt help, i’ll try downloading it from the official website and try again.

here is a pic that describes my problem better than i can with my lacking english skills.

Fehler - abload.de

nooberdev | 2017-08-30 11:33