timer doesn't work when 'autostart' option is off

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By diem55555

This is the tutorial I’ve been following.
In the tutorial ‘autostart’ in timer node is off and enemies are spawned without any problem.

I wrote the exact same code except for a few variable names.
However, in my projects, when ‘autostart’ is off, enemies do not appear at all.
I found out when I turn on the ‘autostart’, enemies are spawned just like the tutorial.
I don’t understand why the code works differently when I’m using the same code.
I want to know how can I make it work with ‘autostart’ turned off.
Because I want first enemy to appear after 3 seconds, not right away.
This is my code. >> extends Node2Dvar preloaded_enemies := [ preload("res://source/actors/Enem - Pastebin.com

Thank you in advance. :))

:bust_in_silhouette: Reply From: horsecar123

If you want a timer to work you need to start it , autostart starts the timer by default so its same as
func ready ():

:bust_in_silhouette: Reply From: Gamespot

note the following :

this is user defined function : ready()
this is already defined virtual function : _ready()