Touch Screen Buttons doesn't respond to their Action

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By codelyoko373

I’m trying to implement some touch screen buttons for my mobile game and I’m having an issue making them actually respond. They work fine in that they actually respond to touch and are pressed but they don’t run the Action they’re meant too.

For example one of my buttons is simply meant to move the player right:
enter image description here

It’s meant to call the Right action from what I understand set out within my project’s input map:
enter image description here
But it just doesn’t. It does nothing when clicked on and I’ve tried it with other keys and it still doesn’t respond.

Does anyone know why?

:bust_in_silhouette: Reply From: ruruarchy

check the project setting > general > input devices > pointing > emulate touch from mouse > on

The OP isn’t asking how to emulate touch input on a PC. The button is responding, but it is not sending the action it is meant to send.

I am experiencing the same issue right now. For me it actually works on my PC using the “emulate touch from mouse” flag, and even on a mobile device (Android) the button texture goes from normal to pressed. But weirdly the action only triggers on PC not on mobile device.

Does anybody have a suggestion on how to troubleshoot this?

aea0ccf9 | 2022-10-13 18:14

I think you should add your action into InputMap, so maybe it works.

noha | 2023-01-13 03:13