Transparency in 3d particles

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Thortilla

Hi everyone.

I am actually creating a small project and I do not know how to make the 3d particles transparent. After watching some tutorials and reading some documentation I am not able to get the effect that I want.

I want to make the trails of a boat, I setted 2 particles nodes that creates Quad Meshes moving out of the ship and growing through time. Now, I want to make them smoothly disapears through time, but when I change the parametres in the Albedo category to make them transparent it just do not work.

I have set in the draw fasses 1, the quad mesh material with the flag “vertex_color_use_as_albedo” on, and I have created in the proccess material a color gradient that go from a white color to a transparent one but from some reason the particles do not make transparent through time. Changing the Alpha color in the Albedo part, I am not be able to make the particles transparent, I do not know why. I have created a small video in order to show you the problem:

I am using Godot Engine v3.3.4 stable official.

I want to recreate this kind of behaviour in the particles (5:00):

I am new in 3d particles and for sure there is something that I am missing, but I do not know what it is, I hope you can help me.

:bust_in_silhouette: Reply From: Inces

The main thing You are missing is that ALBEDO is first Vector3 of Color, without 4th value, which is ALPHA ( transparency ).
You need to check TRANSPARENT to true, in FLAGS property of material, and You will be able to set alpha in albedo just like You tried.

The problem is that Transparency is setted to true in the example, that is why I am so confused because I cannot find what it is missing. There is a capture image of the flags that I have activated in the Draw pass 1 material:

Screenshot - 5675f6f49b38ccb443c5cfbe03371dba - Gyazo

Thortilla | 2021-11-30 19:52

It is fixed, it seems to be a problem with the option “Alpha Scissors”. It was activated to eliminate the black square in which my texture was in. Thank you very much!

Thortilla | 2021-12-01 21:20