Trouble running Godot built from source

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By kitfox

I decided to try building my own Godot engine on Windows 10/64. I followed the instructions on the git website and was able to produce the binary (I used powershell as my command line - not sure if that would make a difference).

The fist thing I noticed is that Godot would crash immediately if I double clicked on the binary in Explorer, but not if I ran it from the command line. After running it from the command line, I was able to create a new project, but then Godot crashed while opening my new project.

Not sure what I’m doing wrong here. The master branch of Godot appears to be using Vulkan for projects which is different from the OpenGL 3 the current stable build uses. I also get some messages about Vulkan starting up just before the crash. Then again, that might just be a coincidence.

I just tried running from the command line again, and now Godot is even crashing in that situation. Below is what is printed to the console. How do I get this to work?

PS D:\dev\\godot\bin> .\
Godot Engine -
ERROR: WARNING : GENERAL - Message Id Number: 0 | Message Id Name: Loader Message
        ReadDataFilesInRegistry: Registry lookup failed to get layer manifest files.
        Objects - 1
                Object[0] - VK_OBJECT_TYPE_INSTANCE, Handle 2037940872752
   at: VulkanContext::_debug_messenger_callback (drivers\vulkan\vulkan_context.cpp:143)
VK_KHR_incremental_present extension NOT AVAILABLE

VK_GOOGLE_display_timing extension NOT AVAILABLE

Vulkan physical device creation success o_O
uniform total: 0
uniform total: 0
uniform total: 0
compilation success

Since the Vulkan branch was recently merged, there’s bound to be many bugs. The only course of action I can think of is opening an issue on the engine’s issue tracker.

Ertain | 2020-02-26 16:28

:bust_in_silhouette: Reply From: Bernard Cloutier

It’s probably safer to stick to the 3.2 branch until the vulkan branch is done: GitHub - godotengine/godot at 3.2

I built it just fine a couple weeks ago.

It looks like you lack the Vulkan SDK. You can get it here if you want to keep trying: Vulkan® SDK - What's in the SDK - Where to Download

Building 3.2 worked for me.

kitfox | 2020-02-26 20:32