Trying to use png image as a texture in 3D, not getting even remotely what I expected

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By JimG

I’m trying to create an image of a planet for the intro to a project I’m working on (my first game, or technically, my second first game, as the real first was lost in a major system snafu). I have several PNG files that are great images of a fake, habitable planet. But when I add them as done in a tutorial (step by step—see next bit), I get two different results. In the Inspector display, I get the view of the textured sphere as expected. In the actual view (camera), I get nonsense.

I followed these steps, right out of a tutorial:

  1. Create a new Spatial node
  2. Create a child node: mesh instance
  3. Create a child node of the mesh instance: CSGSphere (used that instead of NewSphereMesh per other tutorials)
  4. Click on Material in the Inspector, blank sphere appears
  5. Increased Lines and Rings to smooth out the sphere (also another tutorial)
  6. Click on the sphere; more options open
  7. Add planet texture to Albeto

In the tutorial, both the “preview” image in Inspector and the one in the 3D scene are identical. In MY case, I get the right image in the “preview”, but a bunch of bands in the sphere that don’t make any sense, as shown in the following image:

I’ve been trying to get this right for far too long…it’s way past time for me to ask for help.


Is there a reason for using a CSGSphere instead of a regular mesh instance sphere?

dari0us | 2020-10-10 08:03

Just that most of the other tutorials I saw used it. I’m just learning to use the 3D editor in Godot 3…2 … I figured, I’d learn it first and use it when I can, and learn (re-learn … I scratched the surface with Blender about 15 years ago) Blender when I have to use Blender.

JimG | 2020-10-10 11:47

:bust_in_silhouette: Reply From: JimG

Not sure what happened to my answer that I typed out, but here’s the short(er) version. I’m also not sure if this (or another forum) is where I’m supposed to edit the title and add “Solved” to it, but if it is, I can’t remember how to do that.)

First, the previous question got me wondering if the different type mesh might be the issue. It was. I don’t know what the difference is, but the normal mesh worked.

Just FWIW, the planet i’m creating is Epsilon Eridani (Eri) 4, home to a colony of over 200,000 human men, women, and children. The planet is attacked by a missile fired from behind the camera. It then rapidly goes from its blue-green to grey and rapidly to a brilliant white…and then rapidly fades into nothing, leaving only stars in the background.

That’s the intro to my game (a FPS). The working title is:
“Epsilon Eri 4: Mission: Payback”

While in the shower one day, the entire game (from the intro to the player getting an intelligence report to both total victory and side-missions which, failing to reach total victory, give at least partial victory) played out in a flash across my brain.