Tween property interpolation returns true, but does nothing.

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Josh

I’m currently trying to move a 3D camera on the Z axis smoothly using Tween.interpolate_property, and it’s returning true with no errors, warnings or anything. However, the camera itself will not move ingame at all. I’ve tried setting custom Vector3s instead of subtracting numbers but nothing will work. The camera will not move.

Here’s my actual function, cam being the 3D camera node, and tween being the tween node:

tween.interpolate_property(cam, "translation", cam.translation, cam.translation - Vector3(0,0,13), 1, Tween.TRANS_QUART, Tween.EASE_IN_OUT)

Edit note: I configured the on_tween_completed function to print, and it never prints anything, meaning the tween isn’t doing anything I guess based on my limited knowledge.

Have you called tween.start()? Common mistake.

Dlean Jeans | 2019-06-25 00:49

oh no I haven’t but yeah that fixed it, thanks!

Josh | 2019-06-25 02:10