Ugly button hover fills the transparency of my flat button

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By blurymind
:warning: Old Version Published before Godot 3 was released.

Hi I was wondering if there is an easy way to disable the visibility of background panel of the button when it is set to ‘flat’ and the mouse hovers over it

I am drawing my own button background with the patch9 node anyways- when the button is focused however - the flat effect doesnt work. I want my button to stay flat in both focused and non focused states

:bust_in_silhouette: Reply From: blurymind

nevermind, I figured it out

Just set a style override

I need help with this. Can you please be more specific about this? It ruins my button color when I hover the mouse

fuongbregas | 2017-12-01 02:08

I was searching for an answer to this question. When i found this i was like… “someone finally asked the question.” But the answer was a bit vague.

So to be specific cause I was kinda confused by this as well… go into your buttons inspector/ control/ custom styles………. enable “focus” or any other of the 5 options and set “null” too "style-box-empty.

This gets rid of the annoying box that’s visible in the back or front.

marios | 2018-08-06 20:26

How though…

Icewheel12 | 2019-12-21 19:11