Unable to enter the Chinese

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By x1945
:warning: Old Version Published before Godot 3 was released.

Rich Text, GDScript can not enter Chinese?!
Make chat rooms, send messages, but can not enter Chinese?!

:bust_in_silhouette: Reply From: volzhs

You need a font file which contains Chinese characters.

For RichTextLabel

  1. Import > Font
  2. Select font file which has Chinese character at Source Font.
  3. Choose destination folder at Dest Resource.
  4. Choose Character Set > Mode > Unicode
  5. Load imported font file at RichTextLabel > Custom Fonts > Normal Font

For GDScript

1~4. do same 1~4 as above
5. Settings > Editor Settings > Global > Font
6. Load imported font
7. Restart editor

OK, I can enter Chinese, thank you~

x1945 | 2016-04-28 03:35

select best answer if all problems are solved. :slight_smile:

volzhs | 2016-04-28 03:47

Will the fonts be deployed with the application in the export?

Gokudomatic2 | 2016-04-28 07:26

Yes, if it’s located anywhere under res://

volzhs | 2016-04-28 07:31

Thanks. Do you know if it installs the font or if the application loads it independently from the system? Yet I guess the later case is more probable.

Gokudomatic2 | 2016-04-28 07:38

We call it as Font, but it’s actually image (texture).
Godot imports font as a image, and use it on runtime.
So, it’s the later case.

volzhs | 2016-04-28 07:42

Sorry, I can’t input chinese, I’m debian user.

When I paste up text, it show you “\u5982\u4f55\u770b\u5f85\u9aa8\u\u5982\u4f55\u770b\u5f85\u9aa8\u9abc\u52a8\u753b\u7f16\u8f91\u5668”.

NoIE | 2016-06-29 14:24