"Unable to initialise Video driver" when playing a scene

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Newt

Super excited to find a free, open source, well-documented engine to begin some kind of game-making journey on, but wait, what’s this?

Error message
Output in window

This can’t be right; on the download page it says I need “OpenGL 2.1 / OpenGL ES 2.0 compatible hardware” but I checked and I’ve got version 3.1 which should be more than enough (unless I’m misunderstanding).

I’ve tried updating every driver I can find but nothing is helping. Is this a fixable issue or is my hardware actually not good enough?

I’m (trying to) use Godot 3.1 on Windows 8.1.

:bust_in_silhouette: Reply From: Calinou

Your graphics adapter doesn’t support OpenGL 3.3, which is required to use the GLES3 renderer. Therefore, the editor is falling back to the low-end GLES2 renderer. Double-check the video driver used in the Project Settings; it should be GLES2, as this is the only video driver supported by your hardware.

If GLES3 isn’t supported, the editor will fall back to GLES2 automatically when opening a GLES3 project. However, this doesn’t apply to running projects by default (unless you enable Rendering > Quality > Driver > Fallback To Gles2 in the Project Settings), so it will fail to run the project in this case.

It worked! Thank you!

Newt | 2019-07-17 21:43