Unexplained and unexpected occasional game crashes.

:information_source: Attention Topic was automatically imported from the old Question2Answer platform.
:bust_in_silhouette: Asked By Ricardo Noriega

Title pretty much says it all. Usually, the game crashes and there’s a culprit: syntax error, calling a function on a null value, and invalid operation, using undeclared variables or undefined functions, etc. But this is different: the game simply freezes and crashes sometimes. I’ve tried to look for patterns for when it crashes but I’m stumped so far, it seems pretty random. It crashes in at least 3 setups of both Windows and MacOS, and in both, there’s no error log neither in the in-editor debug log nor in the console when compiled. Sometimes I can play seemingly indefinitely, sometimes the game crashes after a minute or two, and that’s with replicating play as close as possible (it’s an action game with heavy RNG in the enemy AI so doing exactly the same is not super feasible). The exported game file crashes as well by the way.

It looks like it’s a performance thing, but the game runs silky smooth until it abruptly crashes. I’ll attach some screenshots for more context I guess.

I know this is super vague so I don’t expect a concrete answer, but maybe I could get some insight into how someone that actually knows about this stuff would go about figuring this one out.

In this one the game did not crash, I closed it manually after I defeated the enemy.

In this one, the game crashed about a minute(?) into gameplay.

I actually have no idea what these numbers mean, no clue if they are higher than expected or lower or if enough to cause a crash. If there’s a more convenient way to share these or if you need more info let me know and I’ll do it. We are quite stumped here.

The computers we’ve tried this on are a MacBook Air (11-inch, early 2014), a MacBook Pro (13-inch, late 2016), and a Windows desktop with a 4th gen i5, GTX 980, 8GB ram.

edit: Not sure how I missed this, I’m using 3.0.5.stable.official.6a88e22.

Which version of the engine were you using? 3.0.5? 3.0.6? A custom built version?

Ertain | 2018-08-31 16:21

I’m using 3.0.5.stable.official.6a88e22

Ricardo Noriega | 2018-08-31 16:24

Is there any way you can use a debugger on the engine binary? For instance, on Linux Mint, I can use gdb to run the engine, and walk through the processes. Also, you may be able to export the game with debugging. If you can, run the game from the command prompt/command line with debugging, and see what pops out.

Ertain | 2018-08-31 21:56